Back to overview
Resolved
KiwiCV goes live!
Jun 10, 2026 at 10:00pm UTC
Affected services
kiwicv.co.nz
App
API
Resolved
Jun 10, 2026 at 10:00pm UTC
🎉 It’s launch day! If you’re looking to work in New Zealand, our CV & cover letter service ensures your docs meet local standards. Expect comprehensive rewrites, free revision rounds and polished templates.
Affected services